viernes, enero 18, 2008

Truco: usar Firefox en el portal IDSE del IMSS

El truco es sencillo es usar el completemento (Add-On) de Firefox llamado IE Tab, el cual utiliza el motor de Internet Explorer para cargar las paginas que se visitan con Firefox.

Importante es tener una versión reciente de Java. En este caso lo mas práctico es visitar www.java.com, además de contar con el complemento de Java Policy que se obtiene desde la misma pagina de http://idse.imss.gob.mx.

Clipboard01

Empecé a tener problemas queriendo cargar esta pagina después de la instalación de Adobe Flex, pues se estaban ejecutando diferentes máquinas virtuales de java. Tuve la puntada ejecutar el CCleaner, pensando que se quedaban por ahí los archivos temporales en la carpeta de Internet Explorer, pero no fue hasta que leí el registro de errores de la máquina que entendí que pasaba. Desgraciadamente se borró algo mas en esa máquina y de plano ya no se ejecutan ningún javascript. Por la fecha y las prisas, decidí moverme a otra computadora, para realizar movimientos en la pagina de IDSE, pero no quería mover la configuración de seguridad de la nueva computadora, ya que no soy yo el que la utiliza de manera diaria.

Instale en un USB, firefox portable, supuse que entraría sin problemas con FF. Error!. Resulta que en realidad la pagina del IDSE, maneja unos ActiveX, es asi que requiere a fuerzas el IE. Entré a Google y en un foro encontré que existe algunos usuarios usaban navegadores basados en el motor de IE, para entrar.

Clipboard02

Y recordé el IE Tab de firefox. Funciona de maravilla. Lo único que se debe hacer es configurar las opciones del complemento las direcciones del imss:

http://*imss.gob.mx/*

Clipboard03

Ahora, cuando se entra al portal, en realidad se esta cargando el motor de IE, pero sin modificar la configuración de esa computadora y desde un USB. ;)

Aparece el icono de Internet Explorer de la siguiente manera en la barra de direcciones:

 Clipboard04

 

Listo!

19 comentarios:

Anónimo dijo...

Excelente tip ya que no puedo entrar con firefox a IMSS
saludos

Anónimo dijo...

Hola,¿ entonces en esta navegador la version del JRE no es necesario ocupar la 1.4.1?
¿Solo la mas reciente?

vgarcias dijo...

Eso en realidad lo resuelve la descarga que tienen en IMSS... de Java
Policy

Anónimo dijo...

Que tal.
Realice los pasos que comentas, instale el firefox 3.5 y le agregue el ie tab. Agregue en la parte opciones lo que sugieres pero al poner querer firmarme a la pagina no hace nada. Pongo el certifcado, usuario y password y al presionar accesar se queda sin hacer nada. Me estará Faltando algo?

vgarcias dijo...

Firefox 3.5 A fecha de abril 2008... ? ah caray...
No es todavia version beta... y van en la 3.0???
En cualquier caso, no lo he probado con una version 3. Lo intentare y publicare el resultado.
De todos modos, mientras el add-on IETab funcione deberia de jalar.
Seguro que tienes resulto la parte de Java con el Runtime y el Java Policy que mencionan en el imss?
Saludos

Anónimo dijo...

Que Tal, nuevamente comentado.
Efectivamente la version 3.5 es beta. Tu que version estas usando por que intente en algunas de la version 2 y no me dejaba instalar el ieTab por eso me pase hasta la 3.5.
Por la parte del java policy y JRE los instale de la pagina del imss. De hecho cuando se instala JRE me pregunta que navegador estoy usando y selecciono mozila o netscape.
No se si tenga que realizar algo adicional para que tome jre o el policy.
Saludos

Anónimo dijo...

Que tal, la version 3.5 es beta.
Tu que version estas usando, por que le intente instalar el ieTab a varias de la 2 y no me dejaba por eso brinque hasta la 3.
En cuanto a lo de java, instale el policy y el JRE de la pagina de imss y el JRE en la instalacion pregunta cual es el navegador que estoy usando y selecciono Mozila/Netscape.
Me estara faltando algo?

vgarcias dijo...

Firefox 2.x va con IEtab 1.3
Firefox 3.0 b5 va con IETab 1.5

Pero creo que el problema que tienes va por el lado de Java Policy.
Seguro ya descargaste la ultima version de java y el java policy disponible en la pagina de idse

corremotos dijo...

Pues no funciona!!!
Ya hice todo lo que dices, desinstale el FF, lo instale otra vez pero ahora la version 3.x, instale el IE tab, pero nomas no abre la pagina de IDSE. Tengo instalada la version de Java 1.5 update 7, Java Policy pero no jala, alguna otra opcion?
ME urge!!!!

Anónimo dijo...

Se me bloquea la descarga, me marca un troyano:

Suspicious#banker (Trojan)

sera?

Saludos,
Jose Segundo

Anónimo dijo...

no funciono

apl dijo...

Win vista SI entrar al IDSE.
1o seguir instruccs en xpvista.pdf.2o ir a la pag del idse, si no aparece hasta abajo a la izq Miniaplicación applet_firma started
ver en: Opciones de internet-Programas-Administrar Complementos (Add-ons) donde deben de estar habilitado los archivos ssv.dll y flash9f.ocx.
Para q este habilitado ssv.dll, deben de haber instalado j2re-1_4_2_03-windows-i586-p.exe o anterior.
En panel de Control>java>java>ver config. de timpo de ejecucion de Java Aplicattion y marcar el 1.4.2_03. Despues REINICIAR. Ir a la hoja del IDSE y listo. Espero se ahorren los 3 !"#$% dias que me tarde en encontrar la respuesta.
APL

Lord sejo dijo...

lo que dijo apl yo lo probe y no me funciono, no se si tenga que ver que en archivo flash9f.ocx.
el mio en vez de 9 dice 10 ojala y me pueda seguir ayudando por que esto del idse es una monserga Gracias

Carlos dijo...

alguien me puede ayudar, ya instale todo de java, ietab y java para cualkier version, el error que me da en IE y firefox con IEtab es un C:\fakepath\certificado.pfx no es validalaruta, no se que hacer para que no me de este error ayuda urgente

vgarcias dijo...

Posiblemente no tienes permisos sobre el archivo que tiene el certificado, intenta poner el archivo en la carpeta de "mis documentos" y revisar bien los permisos de seguridad en las propiedades del archivo.

Anónimo dijo...

Navego con Firefox 3.5.5, hasta el día 10/11/2009 ningun problema al realizar los movimientos del chafa-IDSE con el complemento IETab,en el SAT, y portales bancarios; el día 11/11/2009 empezaron los problemas, se bloquea y reinicia el navegador, logro entrar depues de varios intentos, revisar movimientos y guardarlos, capturar movimientos afiliatorios, el problema es al firmarlos para enviarlos me manda el mensaje de "SERVIDOR NO DISPONIBLE".
Sospecho que realizaron alguna actualizacion o cambio al sistema del IDSE.

Lo intente con IE y pasaron sin ningun problema.

Anónimo dijo...

C:\fakepath\certificado.pfx no es validalaruta

ESTE ERROR TAMBIEN APARECE EN IE, Y ES FACIL DE RESOLVER... SIMPLEMENTE AGREGA LA PAGINA PRINCIPAL DE IDSE http://idse.imss.gob.mx/imss/ A TUS SITIOS DE CONFIANZA, HAY OCASIONES QUE TE ABRE OTRA PAGINA SECUNDARIA PARECIDA A LA PAGINA DE INICIO PERO CUALQUIERA QUE LE DES COMO PAGINA DE CONFIANZA ESTARA BIEN. CIERRALA TU NAVEGADOR, ABRELO NUEVO Y LISTO.. TE DEJARA ENTRAR... SALUDOS WALKMAN2312@YAHOO.COM.MX

@ngiie dijo...

Dios¡¡¡¡¡¡¡ Acabas de solucionar el problema q tengo desde hace siglossss, siempre se me complicaba entrar a la pagina del idse. Pero lei tu entrada y lo probe y funciono de maravilla.
Gracias mil¡¡¡

Rapel2910 dijo...

YO TENGO VARIAS EMPRESAS
Y EN LA MAYORIA ENTRA BIEN PERO HAY DOS QUE NO ME DEJA UN MENSAJE DICE"DerImputStream.getLength():LengthTag=91" y otro "Sequence tag error" alguien que me pueda ayudar??????